$re = '/\(ID\:\ (?<resource_id>[a-z|\d|\ |\-]*[a-z])/m';
$str = 'module.sh1.aws_autoscaling_group.search_head: Creation complete after 40s (ID: sh1 - sre-sandbox - search-head)
module.kms_key.aws_kms_key.stack_key: Destruction complete after 22s
module.iam_profile.aws_iam_role.stack_iam_role: Destruction complete after 1s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);