import Foundation
let pattern = #"\(ID\:\ (?<resource_id>[a-z|\d|\ |\-]*[a-z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
module.sh1.aws_autoscaling_group.search_head: Creation complete after 40s (ID: sh1 - sre-sandbox - search-head)
module.kms_key.aws_kms_key.stack_key: Destruction complete after 22s
module.iam_profile.aws_iam_role.stack_iam_role: Destruction complete after 1s
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)