#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<[A-Z][A-Za-z:]*[^>]* ((?!class)[^ @]*)=[^>]*"
Local $sString = "<LinkTo @route="foo.bar" @model={{this.model}} class="fancy-link">" & @CRLF & _
" foo" & @CRLF & _
"</LinkTo>" & @CRLF & _
"<Input @checked={{this.isChecked}} @type="checkbox" class="fancy-checkbox" />" & @CRLF & _
"" & @CRLF & _
"<Foobar class="fancy-foobar" myArgument={{false}} as |foobar|>" & @CRLF & _
" <Foo @customerId={{this.model.id}} page={{50}} />" & @CRLF & _
" <Foobar class="fancy-foobar" myArgument={{false}} />" & @CRLF & _
"</Foobar>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")