using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[A-Z][A-Za-z:]*[^>]* ((?!class)[^ @]*)=[^>]*";
string input = @"<LinkTo @route=""foo.bar"" @model={{this.model}} class=""fancy-link"">
foo
</LinkTo>
<Input @checked={{this.isChecked}} @type=""checkbox"" class=""fancy-checkbox"" />
<Foobar class=""fancy-foobar"" myArgument={{false}} as |foobar|>
<Foo @customerId={{this.model.id}} page={{50}} />
<Foobar class=""fancy-foobar"" myArgument={{false}} />
</Foobar>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}