import re
regex = re.compile(r"<[A-Z][A-Za-z:]*[^>]* ((?!class)[^ @]*)=[^>]*", flags=re.MULTILINE)
test_str = ("<LinkTo @route=\"foo.bar\" @model={{this.model}} class=\"fancy-link\">\n"
" foo\n"
"</LinkTo>\n"
"<Input @checked={{this.isChecked}} @type=\"checkbox\" class=\"fancy-checkbox\" />\n\n"
"<Foobar class=\"fancy-foobar\" myArgument={{false}} as |foobar|>\n"
" <Foo @customerId={{this.model.id}} page={{50}} />\n"
" <Foobar class=\"fancy-foobar\" myArgument={{false}} />\n"
"</Foobar>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")