using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!`)((?:``)*)\$\(";
string substitution = @"$1`$$(";
string input = @"<!doctype html>
<html lang=""en"">
<head>
<body>
text
$computername
$username
text
$('unescaped')
`$('pre-escaped')
``$('unescaped')
```$('pre-escaped')
````$('unescaped')
</body>
</html>
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}