const regex = new RegExp('(?<!`)((?:``)*)\\$\\(', 'gi')
const str = `<!doctype html>
<html lang="en">
<head>
<body>
text
\$computername
\$username
text
\$('unescaped')
\`\$('pre-escaped')
\`\`\$('unescaped')
\`\`\`\$('pre-escaped')
\`\`\`\`\$('unescaped')
</body>
</html>
`;
const subst = `$1\`$$(`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);