import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!`)((?:``)*)\\$\\(";
final String string = "<!doctype html>\n"
+ "<html lang=\"en\">\n"
+ "<head>\n"
+ "<body>\n"
+ "text\n"
+ "$computername\n"
+ "$username\n"
+ "text\n"
+ "$('unescaped')\n"
+ "`$('pre-escaped')\n"
+ "``$('unescaped')\n"
+ "```$('pre-escaped')\n"
+ "````$('unescaped')\n"
+ "</body>\n"
+ "</html>\n";
final String subst = "$1`$$(";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}