re = /(?<!`)((?:``)*)\$\(/i
str = '<!doctype html>
<html lang="en">
<head>
<body>
text
$computername
$username
text
$(\'unescaped\')
`$(\'pre-escaped\')
``$(\'unescaped\')
```$(\'pre-escaped\')
````$(\'unescaped\')
</body>
</html>
'
subst = '$1`$$('
result = str.gsub(re, subst)
# Print the result of the substitution
puts result