using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)\s*,\s*|types:(?:\s*\[)?\s*)""([^""]*)""";
string input = @"fd types:[""a""]
s types:
[""b"",""c""]
types: [
""one""
]
types: ""two""
types: [""three"", ""four"", ""five"",""six""]
no: [""Don't"",""read"",""this""]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}