import re
regex = re.compile(r"(?:\G(?!^)\s*,\s*|types:(?:\s*\[)?\s*)\"([^\"]*)\"", flags=re.MULTILINE)
test_str = ("fd types:[\"a\"] \n"
"s types: \n"
" [\"b\",\"c\"]\n"
"types: [\n"
"\"one\"\n"
"]\n"
"types: \"two\"\n"
"types: [\"three\", \"four\", \"five\",\"six\"]\n"
"no: [\"Don't\",\"read\",\"this\"]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")