import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!^)\\s*,\\s*|types:(?:\\s*\\[)?\\s*)\"([^\"]*)\"";
final String string = "fd types:[\"a\"] \n"
+ "s types: \n"
+ " [\"b\",\"c\"]\n"
+ "types: [\n"
+ "\"one\"\n"
+ "]\n"
+ "types: \"two\"\n"
+ "types: [\"three\", \"four\", \"five\",\"six\"]\n"
+ "no: [\"Don't\",\"read\",\"this\"]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}