re = /(?:\G(?!^)\s*,\s*|types:(?:\s*\[)?\s*)"([^"]*)"/m
str = 'fd types:["a"]
s types:
["b","c"]
types: [
"one"
]
types: "two"
types: ["three", "four", "five","six"]
no: ["Don\'t","read","this"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end