const regex = /(?:\G(?!^)\s*,\s*|types:(?:\s*\[)?\s*)"([^"]*)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)\\s*,\\s*|types:(?:\\s*\\[)?\\s*)"([^"]*)"', 'gm')
const str = `fd types:["a"]
s types:
["b","c"]
types: [
"one"
]
types: "two"
types: ["three", "four", "five","six"]
no: ["Don't","read","this"]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}