#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\.[a-z_-][\w-]*(?=[^{}]*{[^{}]*})"
Local $sString = ".class-a, #id-a, .class-b:hover { text-align: center; }" & @CRLF & _
"table.simple{background:#fff;}.bg-white{background:#fff;}" & @CRLF & _
"/*# sourceMappingURL=style.css.map */" & @CRLF & _
"/*" & @CRLF & _
"Example comment file.css" & @CRLF & _
"*/"
Local $sSubst = ".a"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)