re = /\.[a-z_-][\w-]*(?=[^{}]*{[^{}]*})/
str = '.class-a, #id-a, .class-b:hover { text-align: center; }
table.simple{background:#fff;}.bg-white{background:#fff;}
/*# sourceMappingURL=style.css.map */
/*
Example comment file.css
*/'
subst = '.a'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result