using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.[a-z_-][\w-]*(?=[^{}]*{[^{}]*})";
string substitution = @".a";
string input = @".class-a, #id-a, .class-b:hover { text-align: center; }
table.simple{background:#fff;}.bg-white{background:#fff;}
/*# sourceMappingURL=style.css.map */
/*
Example comment file.css
*/";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}