use strict;
my $str = '.class-a, #id-a, .class-b:hover { text-align: center; }
table.simple{background:#fff;}.bg-white{background:#fff;}
/*# sourceMappingURL=style.css.map */
/*
Example comment file.css
*/';
my $regex = qr/\.[a-z_-][\w-]*(?=[^{}]*{[^{}]*})/p;
my $subst = '.a';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";