import Foundation
let pattern = #"\.[a-z_-][\w-]*(?=[^{}]*{[^{}]*})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
.class-a, #id-a, .class-b:hover { text-align: center; }
table.simple{background:#fff;}.bg-white{background:#fff;}
/*# sourceMappingURL=style.css.map */
/*
Example comment file.css
*/
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".a"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)