# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/('\d+), (\d+) ?(?=')/\1.\2/g;t' <<< "investimentoEstimado2017 = '735030, 15 ', investimentoEstimado2018 = '735030, 15 ', investimentoEstimado2019 = '306262, 5'
'208137, 6 ' '94057, 47 ' '698572, 87 '"