using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"('\d+), (\d+) ?(?=')";
string substitution = @"\1.\2";
string input = @"investimentoEstimado2017 = '735030, 15 ', investimentoEstimado2018 = '735030, 15 ', investimentoEstimado2019 = '306262, 5'
'208137, 6 ' '94057, 47 ' '698572, 87 '";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}