use strict;
my $str = 'investimentoEstimado2017 = \'735030, 15 \', investimentoEstimado2018 = \'735030, 15 \', investimentoEstimado2019 = \'306262, 5\'
\'208137, 6 \' \'94057, 47 \' \'698572, 87 \'';
my $regex = qr/('\d+), (\d+) ?(?=')/p;
my $subst = '\\1.\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";