# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\+\-]\(+\d+[\*\\/]0\)//gm;t' <<< "(((7+5)*75)+(3*0))+2 = 902
((7+5)*75)+(3*0))+2 = 902
(7+5)*75+(3*0)+2 = 902
(7+5)*75+3*0+2 = 292"