$re = '/[\+\-]\(+\d+[\*\/]0\)/m';
$str = '(((7+5)*75)+(3*0))+2 = 902
((7+5)*75)+(3*0))+2 = 902
(7+5)*75+(3*0)+2 = 902
(7+5)*75+3*0+2 = 292';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;