package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\+\-]\(+\d+[\*\/]0\)`)
var str = `(((7+5)*75)+(3*0))+2 = 902
((7+5)*75)+(3*0))+2 = 902
(7+5)*75+(3*0)+2 = 902
(7+5)*75+3*0+2 = 292`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}