import re
regex = re.compile(r"[\+\-]\(+\d+[\*\/]0\)", flags=re.MULTILINE)
test_str = ("(((7+5)*75)+(3*0))+2 = 902\n"
"((7+5)*75)+(3*0))+2 = 902\n"
"(7+5)*75+(3*0)+2 = 902\n"
"(7+5)*75+3*0+2 = 292")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)