re = /[\+\-]\(+\d+[\*\/]0\)/m
str = '(((7+5)*75)+(3*0))+2 = 902
((7+5)*75)+(3*0))+2 = 902
(7+5)*75+(3*0)+2 = 902
(7+5)*75+3*0+2 = 292'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result