#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[aeiou\s]+|([^aeiou\s])(?:[aeiou\s]*\1)+"
Local $sString = "niarararrrrreghtatt"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)