using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[aeiou\s]+|([^aeiou\s])(?:[aeiou\s]*\1)+";
string substitution = @"$1";
string input = @"niarararrrrreghtatt";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}