const regex = /[aeiou\s]+|([^aeiou\s])(?:[aeiou\s]*\1)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[aeiou\\s]+|([^aeiou\\s])(?:[aeiou\\s]*\\1)+', 'gm')
const str = `niarararrrrreghtatt`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);