$re = '/[aeiou\s]+|([^aeiou\s])(?:[aeiou\s]*\1)+/m';
$str = 'niarararrrrreghtatt';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;