use strict;
my $str = 'niarararrrrreghtatt';
my $regex = qr/[aeiou\s]+|([^aeiou\s])(?:[aeiou\s]*\1)+/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";