re = /[aeiou\s]+|([^aeiou\s])(?:[aeiou\s]*\1)+/m
str = 'niarararrrrreghtatt'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result