import re
regex = re.compile(r"[aeiou\s]+|([^aeiou\s])(?:[aeiou\s]*\1)+", flags=re.MULTILINE)
test_str = "niarararrrrreghtatt"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)