# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!>)(\s)*[\r\n]+/\1/gm;t' <<< "<input>My
Input</input>
<input2>My
input2</input2>
"