$re = '/(?<!>)(\s)*[\r\n]+/m';
$str = '<input>My
Input</input>
<input2>My
input2</input2>
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;