use strict;
my $str = '<input>My
Input</input>
<input2>My
input2</input2>
';
my $regex = qr/(?<!>)(\s)*[\r\n]+/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";