import re
regex = re.compile(r"(?<!>)(\s)*[\r\n]+", flags=re.MULTILINE)
test_str = ("<input>My \n"
"Input</input>\n\n"
"<input2>My \n"
"input2</input2>\n")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)