#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!>)(\s)*[\r\n]+"
Local $sString = "<input>My " & @CRLF & _
"Input</input>" & @CRLF & _
"" & @CRLF & _
"<input2>My " & @CRLF & _
"input2</input2>" & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)