using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!>)(\s)*[\r\n]+";
string substitution = @"\1";
string input = @"<input>My
Input</input>
<input2>My
input2</input2>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}