re = /(?<!>)(\s)*[\r\n]+/m
str = '<input>My
Input</input>
<input2>My
input2</input2>
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result