#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\[To:\d+\]|\[reply:\d+\]|\[quote:\d+\]|\[返信:\d+\]|\[引用:\d+\]).+(さん)"
Local $sString = "" & @CRLF & _
"[To:1183]user1 - business 1さん[To:1186]user 1 - supplier 1さん" & @CRLF & _
"[To:1191]user3 - business1さん" & @CRLF & _
"[To:1224]user - client 1 (business1)さん"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")