package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[To:\d+\]|\[reply:\d+\]|\[quote:\d+\]|\[返信:\d+\]|\[引用:\d+\]).+(さん)`)
var str = `
[To:1183]user1 - business 1さん[To:1186]user 1 - supplier 1さん
[To:1191]user3 - business1さん
[To:1224]user - client 1 (business1)さん`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}