$re = '/(\[To:\d+\]|\[reply:\d+\]|\[quote:\d+\]|\[返信:\d+\]|\[引用:\d+\]).+(さん)/m';
$str = '
[To:1183]user1 - business 1さん[To:1186]user 1 - supplier 1さん
[To:1191]user3 - business1さん
[To:1224]user - client 1 (business1)さん';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);