import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[To:\\d+\\]|\\[reply:\\d+\\]|\\[quote:\\d+\\]|\\[返信:\\d+\\]|\\[引用:\\d+\\]).+(さん)";
final String string = "\n"
+ "[To:1183]user1 - business 1さん[To:1186]user 1 - supplier 1さん\n"
+ "[To:1191]user3 - business1さん\n"
+ "[To:1224]user - client 1 (business1)さん";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}