// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\[To:\d+\]|\[reply:\d+\]|\[quote:\d+\]|\[返信:\d+\]|\[引用:\d+\]).+(さん)").unwrap();
let string = "
[To:1183]user1 - business 1さん[To:1186]user 1 - supplier 1さん
[To:1191]user3 - business1さん
[To:1224]user - client 1 (business1)さん";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}