# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\[To:\d+\]|\[reply:\d+\]|\[quote:\d+\]|\[返信:\d+\]|\[引用:\d+\]).+(さん)"
test_str = ("\n"
"[To:1183]user1 - business 1さん[To:1186]user 1 - supplier 1さん\n"
"[To:1191]user3 - business1さん\n"
"[To:1224]user - client 1 (business1)さん")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.