# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<="),/:/g;t' <<< "[\"Sender\", \"mail@text.org\"]
[[\"Sender\", \"mail@text.org\"], [\"Date\", \"Fri, 09 Jun 2017 13:29:22 +0000\"]]
[[\"Sender\", \"mail@text.org\"], [\"Date\", \"Fri, 09 Jun 2017 13:29:22 +0000\"], [\"Name\", \"Dude\"]]"