use strict;
my $str = '["Sender", "mail@text.org"]
[["Sender", "mail@text.org"], ["Date", "Fri, 09 Jun 2017 13:29:22 +0000"]]
[["Sender", "mail@text.org"], ["Date", "Fri, 09 Jun 2017 13:29:22 +0000"], ["Name", "Dude"]]';
my $regex = qr/(?<="),/p;
my $subst = ':';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";