using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=""),";
string substitution = @":";
string input = @"[""Sender"", ""mail@text.org""]
[[""Sender"", ""mail@text.org""], [""Date"", ""Fri, 09 Jun 2017 13:29:22 +0000""]]
[[""Sender"", ""mail@text.org""], [""Date"", ""Fri, 09 Jun 2017 13:29:22 +0000""], [""Name"", ""Dude""]]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}